Thursday, November 24, 2011

Mount NTFS or USB disk in single mode boot

http://www.insanelymac.com/forum/index.php?showtopic=232365


Snow Leopard 10.6.4

Recently I had a situation where I couldn’t get into the GUI (even with safe mode –x). I knew I had to replace a certain file on the root with a file I had stored on another drive. Now if this was DOS, it would be trivial to copy the file over – not so in OS X.

In order to use the mount command, we first need to know three pieces of information.
1. The name of the drive we want to mount (what do we call it?)
2. The type of file system that drive uses.
3. The folder we are going to mount the drive in.

First we need to enter Single User Mode. For Chameleon-type hackintosh bootloaders, hit any key then type –s enter. For legit Mac users I think you hold Apple and s key as you boot.

After booting, somewhere on the screen, you should see a line similar to this:
BSD root: disk0s1, major 14, minor 1
This tells us that we are currently on disk 0, partition 1 (ignore the major, minor).

You can now go ahead and enter the two commands listed on the screen.
fsck –fy
mount –uw /

The first command will check your disk for errors and the second will give you write access to the root. You now need to be EXTREMELY CAREFUL about making inadvertent or damaging changes to root.

We need to know what the computer has called our drives and partitions. We use the ls command (similar to dir in DOS).
ls –l /dev/disk*

We get some output which contains something like this:
/dev/disk0
/dev/disk0s1 <-- we know we are on this partition
/dev/disk0s2
/dev/disk1
/dev/disk1s1
/dev/disk1s2 <-- the file we want is here (we think)

Note this list seems to change and there is no guarantee that partitions named in the GUI using diskutil will have the same names here. Also CD’s and DVD’s take a while to show up sometimes so just repeat the command (use up arrow) until they do.

Check the file system used by the drive we want to mount. In my example it is a Windows NTFS partition.
fstyp /dev/disk1s2
ntfs <-- ok that’s what we expected

Now we create a folder to mount the drive to. For easy access let’s make a folder on the root called “drive2”.
mkdir /drive2

Now it’s time to use all this information in the mount command
mount –t ntfs /dev/disk1s2 /drive2

With some luck it worked. We check to see if our files and folders are there.
ls –l /drive2

If the device was a HFS/HFS+ volume (Mac OS) then we would use this command:
mount –t hfs /dev/disk1s2 /drive2

USB hard drives and flash drives would use similar syntax depending on what file system the device was formatted with eg. NTFS (windows), HFS (mac), MSDOS (older / smaller usb sticks).

For a CD…
mount –t cd9660 /dev/disk1s2 /drive2

For a DVD…
mount –t udf /dev/disk1s2 /drive2
if this doesn’t work then try the cd9660 switch as if it was a CD.

Mounting a Samba network share does not seem to work in Snow Leopard 10.6.4.

At this point you should be able to do the things you wanted to do (cp files etc.). Note, HFS drives are mounted with WRITE ACCESS by default even if the root is read-only (use -r switch if you want to mount read-only). NTFS drives are mounted as read-only and there is no native support for write access.

We can unmount the device using this command (note spelling of “umount”):
umount /dev/disk1s2

When you are finished, use the reboot or shutdown command. DO NOT use the exit command which will continue booting into GUI.

NOTE: Please do not reply to this thread to troubleshoot your problems. I'm not an expert, I just taught myself what I needed to know to get the job done. Single User Mode has an excellent man command (short for manual). This is the best way to teach yourself. Also look in the /sbin folder for variations of the mount command for other file systems.

If you have something useful to add, for example you know how to get SMB shares to mount, then please contribute.

Monday, November 21, 2011

Modify Chameleon boot loader

After installing os X in PC, chameleon boot loader was installed as default.
It looks charming and I decided to use it.

But one thing left not resolved.
Windows 7 is my primary OS but this loader choose snow leopard as default os.

The way to change the default OS in chameleon was found in follwing location.

http://www.insanelymac.com/forum/lofiversion/index.php/t160689.html
Modify your com.apple.Boot.plist to contain the following:

Default Partition
hd(x,y)

where X is the drive and Y the partition.

Sunday, November 20, 2011

Hackintosh 10.6.6

Just installed hazard snow leopard 10.6.6.
First I tried to update from IOAK 10.6.2 but don't know how to upgrade it safely.
So I decide to reinstall it.

Install process was successful.
While installing, customizing it with PCEFI, NVinjector, NVenabler, AppleAzailla, etc.

But after the install, first boot was failed.

in the verbose boot I found that AppleIntelCPUPowerManagement.kext cause the kernel panic.

kernel panic message read like this;


Debugger called:
Backtrace (CPU 1), Frame : Return Address


Kernel Extensions in backtrace(with dependencies):
com.apple.driver.AppleTyMCEDriver(1.0.1dB)@0x2f5c8000->0x2f5d0fff
dependency: com.apple.iokit.IOPCIFamily(2.6.3)@0x2f922000
dependency: com.apple.driver.IOPlatformPluginFamily(4.0.1d0)@0x35b13000
dependency: com.apple.iokit.IOACPIFamily(1.3.0)@0x2f905000


Following solution was found through google search.

http://www.insanelymac.com/forum/index.php?showtopic=65137&mode=threaded&pid=461289

Try to remove "AppleIntelCPUPowerManagement.kext".

In terminal:
mount -uw /
sudo rm -R /System/Library/Extensions/AppleIntelCPUPowerManagement.kext
sudo rm /System/Library/Extensions.kextcache
sudo rm /System/Library/Extensions.mkext

Then repair permissions and reboot.

Here is the another solution'

http://www.insanelymac.com/forum/lofiversion/index.php/t220378.html

Boot in single user:
mount -uw /
rm /System/Library/Extensions/AppleTyMCEDriver.kext


http://www.hackint0sh.org/f200/43669.htm


[Solution] System Hangs on ACPI_SMC_PlatformPlugIn

If you had this hangs/freeze with this component call, have this sollution:

-

Boot your PC.

Pressing F8 repeatedly.

You see Darwin prompt, now type -S (Enter)

Now, you see something lines, bla bla bla and a prompt.

Now, type:

/sbin/mount -uw / (Enter)

rm -rf /System/Library/Extensions/AppleSMC.kext (Enter)

rm -rf /System/Library/Extensions.mkext (Enter)

rm -rf /System/Library/Caches/* (Enter)

reboot (Enter)

Pressing F8 repeatedly. (Again)

In Darwin prompt, type -v (Enter) (this for verbose mode)

See it boot fine without errors.

Goodluck,